Skype 2.1 (Beta) на Debian Squeeze x86_64

Skype за Debian Squeeze x86_64

Генерални проблем са Skype код линукс дистрибуција за x86_64 архитектуру је тај што не постоје „native“ x86_64 пакети већ се користе они за i386 архитектуру, и то кроз емулацију исте. Тако за функционисање Скајп захтева инсталиране 32битне Pulse Audio библиотеке.

Одавно сам имао инсталиран Skype 2.0.нешто, па сам решио да га (ручно) надоградим на свежу верзију 2.1.0.81. И не би то био никакав проблем да на „дупло битнијем дебиану“ не користим неке експерименталне пакете из Debian Squeeze издања, међу којима је и новије издање libpulse библиотека. На жалост, нови пакет са скајпове странице за преузимање направио је привремени застој.

Преузмем лепо x86_64 пакет Скајпа за Убунту skype-ubuntu-intrepid_2.1.0.81-1_amd64.deb, инсталирам га наредбом

sudo dpkg -i skype-ubuntu-intrepid_2.1.0.81-1_amd64.deb

и кренем да га покренем. Отвори се дијалог за пријављивање, укуцам скајп име и лозинку, стиснем Ентер, започне секвенца пријављивања и кад треба да ме звучно обавести о успешном пријављивању програм пукне уз поруку о грешци:

urke@dionis:~/Downloads$ skype
Inconsistency detected by ld.so: dl-open.c: 611: _dl_open: Assertion
`_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!
Skype 2.1 (Beta) на Debian Squeeze x86_64
Skype 2.1 (Beta) на Debian Squeeze x86_64

Мајку му, а до малопре је Скајп радио најнормалније. Но, решење овог проблема налази се у датотеци README унутар tar.bz2 пакета, где пише:

* On Debian amd64 version Skype crashes on startup with the message:
Inconsistency detected by ld.so: dl-open.c: 623: _dl_open: Assertion
`_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!

This seems to be Debian only issue with 32 bit PulseAudio libraries being installed even if PulseAudio is not active, a workaround can be:
– Debian Lenny:
sudo chmod a-r /usr/lib32/libpulse{-simple.so.0.0.1,.so.0.4.1}
– Debian Squeeze:
sudo chmod a-r /usr/lib32/libpulse{-simple.so.0.0.2,.so.0.8.0,common-0.9.15.so}

Значи, једно лагано RTFM решило је новонастали „квар“.

Објављено од стране

Александар

Самостални веб програмер. Дугогодишње искуство у развоју веб софтвера коришћењем WordPress, PHP, jQuery, HTML5, CSS3 (SASS/LESS).

8 мишљења на „Skype за Debian Squeeze x86_64“

    1. Zar na ubuntu alsa nije ispod pulsea? :))

      Ja sam pre par godina kod kuce imao media PC, koji je bio samo prikacen na TV i zvucnike, a poshto sam uglavnom za laptopom radio, onda mi je bilo zgodno da koristim pulse da kroz mrezu pustim zvuk sa laptopa na media PC na koji su zvucnici prikaceni.

  1. Jest alsa ispod pulsa, ali valjda kapirate da ima ljudi kojima jedino treba zadovoljavajuci zvucni izlaz??? :) Tu je meni alsa na prvom mestu ako mogu da biram, jednostavno radi a prednosti pulsa me u tom slucaju ne interesuju…i ako mogu da dodam, jedino je oss4 bolja varijanta, ali to sam koristio kad sam kompajlirao kernel, sad me eto mrzi, znaci alsa zavrsava posao…

  2. Samo da dodam da je istina da na 64-bit Ubuntu nema nikakvih izmena i da posle postavljanja istog izdanja .deb paketa (i podešavanja u skajpu odakl mu dolazi i gde ide zvuk), sve radi.

    Inače, imam Debian u VirtualBox, samo da bih mogao da pokrećem skajp na jednoj mašini i takođe lepo radi ali u pitanju je 32-bitni Debijan i njemu nije potrebna prepravka da bi radio.

Оставите одговор

Ваша адреса е-поште неће бити објављена. Неопходна поља су означена *